We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 22:29 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 22:21 UTC
Update
We are seeing meaningful improvement in services and partners as AWS reports recovery, but we are yet to see total recovery amongst all our partners. Assist AI Voice remains falling back to human agents.
Posted Oct 20, 2025 - 21:15 UTC
Update
We are continuing to monitor as AWS reports recovery, but we are yet to see all partners' services recover. Assist AI Voice remains falling back to human agents.
Posted Oct 20, 2025 - 19:00 UTC
Update
We are continuing to monitor for improvements in upstream providers' services. Assist AI Voice remains falling back to human agents.
Posted Oct 20, 2025 - 18:10 UTC
Update
We are automatically falling back to human agents from Assist AI Voice, and are working with upstream providers to resolve this as soon as possible.
Posted Oct 20, 2025 - 17:36 UTC
Update
We are observing issues with multiple integration partners including Kustomer and Zendesk that are making handoff and connection between AI agents and ticketing systems unstable.
Posted Oct 20, 2025 - 17:13 UTC
Update
We are also seeing ongoing issues syncing QA data with the MaestroQA platform, due to errors with MaestroQA's API.
Posted Oct 20, 2025 - 17:10 UTC
Update
We are aware that our integrations with Kustomer are not working as expected at the moment due to issues connecting to Kustomer's API. This affects real-time data, reporting, and AI agent handoff. (AI agent handoff via Kustomer has been disabled.) See their status page for more details: https://status.kustomer.com/
Posted Oct 20, 2025 - 17:01 UTC
Monitoring
Our upstream provider issues are beginning to resolve, and we're seeing reporting and real-time services slowly get back to normal. There may continue to be some delays and unexpected issues caused by third-party integrations, since some other products are also experiencing connectivity issues at the moment.
Posted Oct 20, 2025 - 16:16 UTC
Identified
The issue with real-time and reporting services is due to upstream provider networking issues affecting much of the internet's infrastructure. We are awaiting a resolution from the provider.
Posted Oct 20, 2025 - 15:09 UTC
Investigating
Due to the earlier incident caused by upstream provider service outages, some reports have delayed data, and some customers are experiencing timeouts while trying to load report data. Real-time notifications may also be impacted. Our team is investigating the issue to identify a solution.
Posted Oct 20, 2025 - 14:57 UTC
This incident affected: Reporting and data services, Assist, and Voice.