Temporarily degraded performance

Incident Report for Assembled

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 19:14 UTC

Update

Snowflake mentioned that they have fixed a problematic change - https://status.snowflake.com/incidents/09f44bx0y6lj. As a result, we are no longer seeing any errors on the Assembled side.

We will continue monitoring before providing a final update.
Posted Aug 31, 2026 - 17:41 UTC

Monitoring

Assembled is experiencing degraded performance due to an ongoing outage affecting Snowflake (https://status.snowflake.com/), one of our upstream data providers. As a result, some customers may see elevated error rates or slow page loads across the Assembled app, including Reports and Queue Configuration, and any reporting APIs.

We're monitoring Snowflake's recovery and will update here as the situation changes.
Posted Aug 31, 2026 - 17:30 UTC
This incident affected: Application, API, Reporting and data services, AI Products, and Voice.