Issues saving events

Incident Report for Assembled

Resolved

We've resolved the issue.
Posted Jun 01, 2020 - 15:38 UTC

Investigating

We are currently investigating issues with saving events.
Posted Jun 01, 2020 - 15:29 UTC
This incident affected: Application.