Google SSO login errors

Incident Report for Assembled

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 16:25 UTC

Identified

Google declared an incident regarding this issue: https://www.google.com/appsstatus/dashboard/incidents/oFcAZTr4EVieF5Fr6Ee9
Posted Jul 18, 2025 - 16:05 UTC
This incident affected: Application.