Service outage
Incident Report for Assembled
Resolved
We've addressed the root cause and restored service. We apologize for the disruption.
Posted Mar 23, 2020 - 19:36 UTC
Investigating
We're currently investigating issues with Assembled. We’re working to fix the problem as quickly as we can.
Posted Mar 23, 2020 - 19:30 UTC
This incident affected: Application.