Voice agent rerouting to live human agents due to elevated latency

Incident Report for Assembled

Resolved

We've returned to normal levels of latency and error rates across all services.
Posted Jul 15, 2026 - 17:24 UTC

Update

We've returned to normal levels of latency and error rates across all services.
Posted Jul 15, 2026 - 17:24 UTC

Update

We are seeing improvement in latency across all services so as a result, we have turned our voice agent back on. It is not accepting calls. We are continuing to monitor for stability.
Posted Jul 15, 2026 - 17:18 UTC

Update

We're still seeing unexpected load on our database, causing elevated latency and error rates. The team is continuing to investigate.
Posted Jul 15, 2026 - 09:26 UTC

Update

Our original fix did not have the intended effect. We've merged another fix and are again monitoring results to see if latency across all services recovers.
Posted Jul 15, 2026 - 06:23 UTC

Monitoring

We've identified the root cause and merged a potential fix. We are monitoring for improvement.
Posted Jul 15, 2026 - 03:00 UTC

Update

We have discovered that the elevated voice latency is due to increased latency from our database, which affects our web application and APIS.
Posted Jul 15, 2026 - 01:07 UTC

Investigating

We are investigating elevated latency with our voice agent so while this occurs we are re routing calls to live agents.
Posted Jul 15, 2026 - 00:40 UTC
This incident affected: Application, API, and Voice.