We identified the root cause as service limits with a downstream service provider. We've fully resolved the issue and voice call performance has been restored. For calls that were routed to us during the period of degraded performance, any errors were successfully routed to the fallback destination in each customer's IVR.
Posted May 20, 2025 - 20:29 UTC
Monitoring
We've implemented a fix and Assist Voice call traffic is now restored for all customers.
Posted May 20, 2025 - 20:13 UTC
Identified
We've identified the issue and are implementing a fix.
Posted May 20, 2025 - 20:12 UTC
Investigating
We are currently investigating an issue with some Assist Voice calls dropping.