Assembled is experiencing degraded performance

Incident Report for Assembled

Resolved

The issue surrounding degraded performance has now be resolved. Thank you for your patience, and apologies for any inconvenience!
Posted Mar 09, 2022 - 18:29 UTC

Investigating

We're currently experiencing degraded performance. We're investigating the root cause of the issue, and we'll share an update as soon as we can. We're very sorry about any inconvenience!
Posted Mar 09, 2022 - 17:39 UTC
This incident affected: Application and API.