Google Calendar syncs are delayed
Incident Report for Assembled
Resolved
We've cleared the backlog and Google Calendar syncs should be up to date going forward. We apologize for the inconvenience.
Posted Mar 19, 2021 - 21:47 UTC
Investigating
We're experiencing delivery delays to Google Calendars. We are currently investigating.
Posted Mar 19, 2021 - 20:20 UTC
This incident affected: Application.