Delayed Google Calendar event creation

Incident Report for Assembled

Resolved

Activities should now be syncing successfully into Google Calendar from Assembled.
Posted Sep 23, 2025 - 07:45 UTC

Update

We are continuing to see a steady recovery.
Posted Sep 23, 2025 - 06:15 UTC

Update

We are monitoring the synchronisation delay for creating events in Google Calendar.
Posted Sep 23, 2025 - 05:23 UTC

Update

We are continuing to monitor the delay in synchronisation.
Posted Sep 23, 2025 - 04:06 UTC

Monitoring

There is a delay synchronising events into Google Calendar after they have created in Assembled. We are aware of the issue, and monitoring for a resolution.
Posted Sep 23, 2025 - 03:00 UTC
This incident affected: Application.