System Slowness
Incident Report for Assembled
Resolved
We've identified the underlying issue and have ensured that there are temporary measures in place to speed up the application. We're also implementing a longer term fix that should resolve the underlying issue.
Posted Mar 17, 2021 - 18:39 UTC
Investigating
We are currently experiencing some slowness and failures on Assembled.
Posted Mar 17, 2021 - 15:59 UTC
This incident affected: Application.