Service outage

Incident Report for Assembled

Resolved

This incident has been resolved. We apologize for the disruption.
Posted Mar 18, 2020 - 16:52 UTC

Investigating

Assembled is experiencing a major service outage. Broad parts of the application are unreachable.
Posted Mar 18, 2020 - 16:50 UTC
This incident affected: Application.