[Resolved] Temporarily degraded API performance

Incident Report for Assembled

Resolved

This is now resolved

The following functionality has now been restored: viewing the Realtime Analysis page, seeing agent states from the Assembled API, and adding an ID for people via the API. We can confirm that no agent state data has been lost.

From 0111 UTC to 1402 UTC, the aforementioned functionality was not available.
Posted Mar 25, 2025 - 14:32 UTC

Monitoring

Agent state data is now syncing as expected via our API and no agent state data was lost as a result of this issue. We are continuing to monitor and confirming root cause.
Posted Mar 25, 2025 - 13:46 UTC

Investigating

Assembled is investigating failures to retrieve agent state data via our API beginning yesterday around 1:00 AM UTC.
Posted Mar 25, 2025 - 13:38 UTC
This incident affected: API.