Degraded syncs for certain Salesforce and Zendesk integration users
Incident Report for Assembled
Resolved
This incident has been resolved.

From 2024-05-02 11:41pm UTC until 2024-05-03 1:11 UTC, a proxy server for our Salesforce and Zendesk syncs had a configuration change and stopped pulling in data. This affected the realtime analysis page as well as reporting on ticket metrics.

We identified the issue and resolved it -- all syncs are now functional. In addition, we've backfilled historical ticket data for this period so that all ticket metrics should be back up to date. We have added an agent state exclusion for this time period for all affected customers to ensure that adherence is not affected.

Thank you for your patience during this incident, our engineering team will be conducting an incident review to identify remediations to prevent similar outages in the future.
Posted May 03, 2024 - 01:31 UTC
Update
We have restored select sync functionality for Salesforce and Zendesk syncs. We are continuing to work on restoring remaining functionality.
Posted May 03, 2024 - 01:11 UTC
Identified
Assembled is experiencing degraded syncs for certain Salesforce and Zendesk integration users. We've identified a root cause and are working on resolving the issue. We apologize for the inconvenience.
Posted May 03, 2024 - 00:33 UTC
This incident affected: Reporting and data services.