[Resolved, now monitoring] Temporarily degraded performance

Incident Report for Assembled

Resolved

We’ve fully resolved this issue and observed no issues with the platform’s performance during the monitoring period. We are finalizing our analysis of the root cause and are committed to ensuring our platform’s pages and reports respond swiftly.
Posted Mar 10, 2025 - 17:27 UTC

Update

We’re pleased to inform you that the recent performance degradations have been resolved. We continue to actively monitor system performance to ensure stability.

The performance degradations occurred from 12:44pm - 13:27pm Eastern Standard Time.

If you experience any further issues, please contact our support team at support@assembledhq.com.
Posted Mar 03, 2025 - 20:40 UTC

Update

Some users may still be experiencing slow load times. We are continuing to investigate and resolve the issue. We appreciate your patience.
Posted Mar 03, 2025 - 19:10 UTC

Update

Some users may still be experiencing slow load times. We are continuing to investigate and resolve the issue. We appreciate your patience.
Posted Mar 03, 2025 - 18:50 UTC

Update

Some users may still be experiencing slow load times. We are continuing to investigate and resolve the issue.
Posted Mar 03, 2025 - 18:37 UTC

Update

Some users may still experience slow load times. We are continuing to investigate and resolve the issue.
Posted Mar 03, 2025 - 18:25 UTC

Monitoring

Assembled load times are now back to normal. We appreciate your patience here.

We experienced slow loading times from 12:44 PM Eastern to 12:54 PM Eastern.
Posted Mar 03, 2025 - 18:14 UTC

Investigating

Assembled is experiencing degraded performance, which may cause slow load times.
Posted Mar 03, 2025 - 17:59 UTC
This incident affected: Application, API, Reporting and data services, and Assist.