Elevated latency and error rate on web application and APIs

Incident Report for Assembled

Resolved

All APIs and the Assembled web application are fully functional.
Posted Jul 13, 2026 - 18:53 UTC

Monitoring

We've identified the root cause and are working on a potential fix, monitoring the results to see if this will reduce pressure on our database and restore latency and error rates to normal baselines.
Posted Jul 13, 2026 - 18:25 UTC

Investigating

We are experiencing a slight increase in latency and timeout-related errors on our web application and APIs. We are actively investigating the issue.
Posted Jul 13, 2026 - 15:30 UTC
This incident affected: Application and API.